|
Technote (troubleshooting)
Problem(Abstract)
Your application server terminated without warning or a system core is generated but you are not sure what data to collect. The following MustGather will assist you in collecting the critical data to troubleshoot issues with an IBM? WebSphere? Application Server crash on the AIX? platform.
Resolving the problem
Your application server terminated without warning or a system core is generated but you are not sure what data to collect. The following MustGather will assist you in collecting the critical data to troubleshoot issues with an IBM? WebSphere? Application Server crash on the AIX? platform.
To improve the accuracy of complete data collection, IBM recommends you use the automated data collectors within IBM Support Assistant. Not only will the automated collector gather the equivalent of the manual process, it will also provide a secure file transfer of the collection to IBM.
Collecting data using the IBM Support Assistant Data Collector
- Go to the ISA Data Collector site for WebSphere Application Server.
- Start the ISA Data Collector:
- To run online, select the option to collect from this system using the current browser and click Start Collection.
- To run locally, select the option to collect from this or another system using a downloadable utility. Download and extract the zip file to your WAS_HOME directory. From a command line, run isadc.[sh|bat] or launch index.html to use the web interface.
- To run online, select the option to collect from this system using the current browser and click Start Collection.
- Select the JDK > Crash Problem collector and click Start.
- Follow the prompts to automatically submit the collected data to IBM Support.
Collecting data manually
Collecting the Required Data |
Locate the system core, with the filename core* . Rename the system core so it does not get overwritten.
If a core file is not found, see Crash on AIX produces no core or truncated core.
Processing the Core |
It is critical that jextract is run against the system core.
Instructions for the execution of jextract can be found in this technote:
How to process an IBM SDK core dump with jextract
http://www.IBM.com/support/docview.wss?uid=swg21577379
Executable Scripts |
Run aix_osinfo.sh and collect the resulting aix_osinfo_RESULTS.tar.gz and aix_osinfo.log files. This script collects general information about the AIX operating system.
./aix_osinfo.sh
Commands executed in this script above include:
- /usr/sbin/emgr -lv3 (if the root user)
- oslevel -s
- lslpp -la
- instfix -ia
- prtconf
- lparstat -i
- lsattr -El sys0
- df -k
- errpt -a
- ps -ef
- Set the [JVM_PATH] to the following directory:
install_root/java/jre/bin/java
For WebSphere Application Server 5.1.1 and 6.0.2 |
The rest of the scripts below are designed for WebSphere Application Server 6.0.2 and below, and are only needed if jextract fails or IBM support specifically asks for this data. These scripts require DBX installed on the system.
./dbxtrace_aix.sh [JVM_PATH] [CORE_PATH] > dbxtrace.out
./getlib.sh [JVM_PATH] [CORE_PATH]
Notes:
Collecting the Logs |
Collect all the server logs from the server that crashed:
profile_root/logs/server_name/*
- Server / native logs
- All javacore*.txt files
- dbxtrace.out
- core*.zip or core.sdff generated by jextract
- errpt.out
- aix_osinfo_RESULTS.tar.gz and aix_osinfo.log
- getlib_archive.tar.Z (Only if asked to collect)
Submitting required data
Gather the following files:
Send the results to IBM support.
Frequently Asked Questions (FAQ) |
- What is a core file and where is it located?
A system core, or core file, is a binary snapshot of the JVM process. It is generated when a process is terminated. Search the current working directory of the JVM to locate the core file.
Javacores are readable text files containing thread dumps. - How can I prevent a truncated system core?
Ensure that your system is set up to create full system cores.
Set your ulimits to unlimited:
ulimit -c unlimited
ulimit -f unlimited
Make sure enough file space is available for the generation of system cores. The size of the core depends on your JVM's heap settings.
Make sure proper file permissions are set.
For additional information, see Crash on AIX produces no core or a truncated core. - What if I am using WebSphere Application Server V5.1? Where are the server logs?
For WebSphere Application Server V5.1, the logs are located here:
install_root/logs/server_name/*